Author Topic: nc.windows.app.23792 & 24061  (Read 120129 times)

wescalkins

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
nc.windows.app.23792 & 24061
« on: May 04, 2007, 01:04:17 pm »
Hi,
I'm using a DELL Latitude D420 with XP SP2.  I have SSL VPN installed and when I clicked on the Network Connect option after logging in, I received the following errors:

Failed to connect to the secure gateway.  Do you want to reconnect?
(nc.windows.app.23792)
and when tried again
Reconnect attempt to the secure gateway failed.
(nc.windows.app.24061)

Any ideas on what causes this error?

Thanks in advance for your help.

Wes


spacyfreak

  • Hero Member
  • *****
  • Posts: 515
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #1 on: May 05, 2007, 12:46:20 am »
1. Check Firewall blocking Ports
telnet <ip-of-your-juniper-sa> 4500
telnet <ip-of-your-juniper-sa> 443

2. Check the Juniper Event Log Files.

3. Do a "Session Recording" on the Juniper to see what happens while user tries to connect

4. Check Juniper Knowledgebase www.juniper.net


nc.windows.app.23663 - Network Connect is already running on the client. Please terminate your existing session before starting a new one.
nc.windows.app.23704 - Connection attempt timed out.
nc.windows.app.23705 - Unable to display connection information.
nc.windows.app.23707 - Cannot open a connection to the NCService component.
nc.windows.app.23708 - Cannot connect to the secure gateway.
nc.windows.app.23709 - Cannot open a connection to the secure gateway.
nc.windows.app.23710 - Unable to retrieve connection information from the secure gateway.
nc.windows.app.23713 - Proxy authentication required to connect to the secure gateway.
nc.windows.app.23714 - Failed to connect to the secure gateway.
nc.windows.app.23715 - Unable to retrieve connection information from the secure gateway.
nc.windows.app.23786 - The Network Connect NCService component is not running.
nc.windows.app.23787 - Cannot start the Network Connect service. Please re-install Network Connect.
nc.windows.app.23791 - The secure gateway denied the connection request from this client.
nc.windows.app.23792 - Failed to connect to the secure gateway.
nc.windows.app.24044 - Network Connect could not initialize the Type of Service (TOS) feature.
nc.windows.app.24045 - Network Connect could not disable the Type of Service (TOS) feature.
nc.windows.app.24058 - You must reboot your computer to disable the Type of Service (TOS) feature. 
nc.windows.app.24059 - You must reboot your computer to enable the Type of Service (TOS) feature. 
nc.windows.app.24062 - Launching Network Connect will automatically terminate your W-SAM session, which may render some network resources unreachable.

spacyfreak

  • Hero Member
  • *****
  • Posts: 515
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #2 on: May 05, 2007, 12:47:12 am »

spacyfreak

  • Hero Member
  • *****
  • Posts: 515
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #3 on: May 05, 2007, 12:49:28 am »
This error means Network Connect is unable to establish a connection with the secure gateway.
A variety of causes can contribute to this error, such as the Bonjour component of iTunes, Cisco VPN software, etc.
In these cases, the interfering software has to be uninstalled (Bonjour can be uninstalled leaving iTunes).

The key to determining where to look is, is the error affecting all Network Connect users, or a few Network Connect users.
All users would be a configuration setting is required in the IVE, whereas if only a few users are affected, it could be software.

Another common cause of nc.windows.app.23791 is a firewall preventing Network Connect from establishing a connection.
An end user, if running XP SP2, must have KB884020 patch installed for the loopback IP to work.
Hosts file must not be read only.  Must use Sun Java JVM 1.4.2_04, 1.4.2_06, or 1.5.0_03

Sun JRE 1.4.2_04
http://java.sun.com/products/archive/j2se/1.4.2_04/index.html

Sun JRE 1.4.2_06
http://java.sun.com/products/archive/j2se/1.4.2_06/index.html

Sun 5.0 J2SE 1.5.0_03
http://java.sun.com/products/archive/j2se/5.0_03/index.html


Solution
In this particular case, a 23791 was caused by a Network Connect Connection Profile had not yet been created.
A connection profile provides access to utilize the IVE's DHCP pool to lease an IP address in the same subnet as the internal port of the IVE.
In a connection profile is also where to change the DNS setting to set Use IVE DNS first.

Upon creating a connection profile, it resolved this issue.


spacyfreak

  • Hero Member
  • *****
  • Posts: 515
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #4 on: May 05, 2007, 12:50:10 am »
Network Connect:  What do the dsclient error codes shown in the log files mean?

Solution
0  DSINET_E_SUCCESS  Operation successfully completed 
-1  DSINET_E_CONNECT  Currently not used 
-2  DSINET_E_BUFSIZE  Internal error code - buffer size is not enough 
-3  DSINET_E_SSL  SSL initialization failed 
-4  DSINET_E_HOSTNOTFOUND  Can not resolve host name 
-5  DSINET_E_NOTCONNECTED  There is no httpa connection to IVE 
-6  DSINET_E_ALREADYCONNECTED  trying to start a https connection while a connection exists 
-7  DSINET_E_CONNECTION  DSHTTPConnect failed 
-8  DSINET_E_REQUEST  Not able to send a https request 
-9  DSINET_E_RESPONSE  Error happens when receiving https response 
-10  DSINET_E_MOREDATA  More data to be read from https response 
-11  DSINET_E_NOTFOUND  Retrieve response returned NULL 
-12  DSINET_E_BADPARAMETER  Set proxy with incorrect parameter 
-13  DSINET_E_NOTSUPPORTED  Only https protocol is supported. If open a different protocol, this error is shown 
-14  DSINET_E_INTERNAL  currently not used 
-15  DSINET_E_PROXYAUTH  Need proxy authentication to connect to IVE


spacyfreak

  • Hero Member
  • *****
  • Posts: 515
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #5 on: May 05, 2007, 12:52:26 am »
Users are getting an error stating that the secure gateway denied the connection, what is causing the issue?

Receiving one of the following errors:

nc.windows.app.23663 - Network Connect is already running on the client. Please terminate your existing session before starting a new one.
nc.windows.app.23704 - Connection attempt timed out.
nc.windows.app.23705 - Unable to display connection information.
nc.windows.app.23707 - Cannot open a connection to the NCService component.
nc.windows.app.23708 - Cannot connect to the secure gateway.
nc.windows.app.23709 - Cannot open a connection to the secure gateway.
nc.windows.app.23710 - Unable to retrieve connection information from the secure gateway.
nc.windows.app.23713 - Proxy authentication required to connect to the secure gateway.
nc.windows.app.23714 - Failed to connect to the secure gateway.
nc.windows.app.23715 - Unable to retrieve connection information from the secure gateway.
nc.windows.app.23786 - The Network Connect NCService component is not running.
nc.windows.app.23787 - Cannot start the Network Connect service. Please re-install Network Connect.
nc.windows.app.23791 - The secure gateway denied the connection request from this client.
nc.windows.app.23792 - Failed to connect to the secure gateway.
nc.windows.app.24044 - Network Connect could not initialize the Type of Service (TOS) feature.
nc.windows.app.24045 - Network Connect could not disable the Type of Service (TOS) feature.
nc.windows.app.24058 - You must reboot your computer to disable the Type of Service (TOS) feature. 
nc.windows.app.24059 - You must reboot your computer to enable the Type of Service (TOS) feature. 
nc.windows.app.24062 - Launching Network Connect will automatically terminate your W-SAM session, which may render some network resources unreachable.




Solution

To view the flowchart for the steps listed below, select this link:  KB9306 Flowchart

Use the following steps to assist with resolving issues related to Launching/Establishing a connection with Network Connect:



 Does this affect One user or Many users? For assistance, see: KB9211 - How do I verify which users an issue is affecting?

One User      - Skip to Step 3. 
Many Users - Continue with Step 2.   
  Are the users currently on a supported platform?  Consult:  KB9212 - How do I know if my client system meets the compatibility requirements to access the SSL VPN?

Yes - Skip to Step 2a. 
No   - Resolve the requirements issues and try the connection again.


Have there been any recent network changes?
No   - Skip to Step 2b. 
Yes - Refer to the following link for assistance: KB9258 - How do I verify that there haven't been any network changes?


Are the NCP settings correctly configured? For assistance, see KB9283 - How do I verify the NCP settings?
Yes - Skip to Step 2c.
No   - Correct the NCP settings and try the connection again


Is the NC Connection Profile correctly configured? For assistance, see KB9285 - How do I verify that the NC Connection Profile is configured correctly
Yes - Skip to Step 2d.
No   - Correct the NCP Connection Profile and try the connection again


If there is a proxy configured, is it configured correctly?  For assistance, consult: KB9232 - How do I verify that the external proxy is configured correctly
Yes - Skip to Step 7.
No - Correct the Proxy configuration and try the connection again.
  Is the user currently on a supported platform?  Consult:  KB9212 - How do I know if my client system meets the compatibility requirements to access the SSL VPN?

Yes - Skip to Step 4. 
No   - Resolve the requirements issues and try the connection again.
  Have there been any recent network changes?

No   - Skip to Step 5. 
Yes - Refer to the following link for assistance: KB9258 - How do I verify that there haven't been any network changes?
  If there is a proxy configured, is it configured correctly?  For assistance, consult: KB9232 - How to verify that the external proxy is configured correctly

Yes - Skip to Step 6.
No - Correct the Proxy configuration and try the connection again.
  Does the role/realm settings work for other users?

Yes - Skip to Step 7.
No   - Consult:  KB9105 - How to verify the Role/Realm settings for Network Connect
  Has Network Connect client side logging been turned on?

Yes - Skip to Step 8.
No   - Consult: KB9210 - How to turn on Network Connect client side logging

 Is a software firewall allowing the Network Connect traffic?  For assistance, consult: KB9216 - How do I check that a client side software firewall is not preventing access. 

Yes - Skip to Step 9.
No   - Modify or temporarily disable the software firewall to permit the Network Connect traffic, then try the connection again.
 Has a Network Connect clean uninstall and a reinstall been done?

Yes - Skip to Step 10.
No   - Consult: KB9081 - How to perform a Network Connect clean uninstall
Collect Network Connect logs and open a case with Juniper Technical Support.  Refer to the following link to collect the Network Connect logs and open a case: KB9218 - How to collect the Network Connect logs when opening a case with Juniper Technical

jlucier

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #6 on: May 13, 2007, 06:47:42 pm »
Hi, I would just like to say that I have the same problem with an NC.23792 error code when running Windows XP as a virtual machine on two Mac computers that I have running the most recent version of OS X?  This began happening on both computers a little more than a week ago?  Previously, I was trouble-free. Does anyone know whether a security patch in XP could have caused this problem? I am willing to investigate updates in OS X as well?

jis157

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #7 on: May 23, 2007, 12:54:17 pm »
I recall resolving this once on a user's PC by disabling their AV/ASpyware/Firewall product.

Currently, I've been able to use Network Connect on a fully patched Macintel, with a fully patched WinXP install in a Parallels VM.  NC works on both native OS X and WinXP without issues.

Please post firmware version.

Here's more info:
On the client

1. The error may indicate a faulty Java installation on the client. Have the client uninstall and reinstall the JRE.

2. One or more of the 3rd-party clients on your end-user’s computer may be faulty or interrupting the connection. You will need to check or have your user check clients such as VPN clients, Anti-Virus, Personal Firewalls, Spyware, and other types of endpoint security clients.

3. The \Documents and Settings folder on the end-user’s computer might be encrypted. Network Connect cannot install itself to an encrypted directory.




Hi, I would just like to say that I have the same problem with an NC.23792 error code when running Windows XP as a virtual machine on two Mac computers that I have running the most recent version of OS X?  This began happening on both computers a little more than a week ago?  Previously, I was trouble-free. Does anyone know whether a security patch in XP could have caused this problem? I am willing to investigate updates in OS X as well?
Hardware: SA 6000 (Clustered)
Firmware:  5.5R1

ramas1243

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #8 on: June 08, 2007, 10:27:48 pm »
I am facing a similar problem running Windows vista. Is Vista supported as yet?

jis157

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #9 on: June 11, 2007, 09:51:24 am »
As of 5.5R1, yes.  However, there are some known limitations.

See http://kb.juniper.net/KB9678 for more details.
Hardware: SA 6000 (Clustered)
Firmware:  5.5R1

jovin

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #10 on: July 19, 2007, 12:58:27 pm »
Hi is there any update on this?  I've got Vista on my box and getting the same error.

Failed to connect to the secure gateway.  Do you want to reconnect? (nc.windows.app.23792).  I get this when launching Juniper's Network Connect.  I'm running Juniper Network Connect 5.3.0.11339 if it helps.

TIA>....

jis157

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #11 on: July 19, 2007, 01:21:29 pm »
Not yet.  5.5R1 is still the latest revision.  Looks like you're using 5.3R8 firmware, which is IE7 compatible but not Vista compatible.
http://kb.juniper.net/KB9678
Read the kb article carefully.
Hardware: SA 6000 (Clustered)
Firmware:  5.5R1

jimaw

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #12 on: July 11, 2008, 06:13:22 am »
Try this: Start Regedit
 
HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services -> Tcpip -> Parameters
 
On your right, edit the key ”DisableDHCPMediaSense”
 
Change the value to "0" and "HEX"

Reboot and try connecting to the Juniper SSL again.

Jim

sanjay92

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #13 on: November 04, 2008, 10:31:20 pm »
I have two Laptops both running Vista & IE7. Net Connect is version 5.3
One of Laptop does connects fine, other one throws above mentioned errors. I tried to disable firewall, stopping Mcafee stuff, Downgrade Java version to 1.5 but nothing helped.
I also tried above registery hack but that also did not help.

Rama

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #14 on: November 24, 2009, 06:10:28 pm »

Winsock issue - If the end user is running a Dell with XP SP2, please try:

    Browse to: Start > Run . Enter cmd to enter the command prompt window and issue the following commands:
    netsh
    winsock
    reset

lineolata

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #15 on: January 08, 2010, 11:47:42 am »
I also had the nc.windows.app.23791 error. The prolem was on the server side, not the client. The IVE was not able to acquire a IP address from the DHCP server. Adding a second DHCP server to the address pool solved the problem

druvak

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: nc.windows.app.23792 & 24061
« Reply #16 on: February 15, 2010, 10:24:04 pm »
nc.windows.app.23792 & 24061
Hi,
I'm using a WINDOWS VISTA OS.  I have SSL VPN installed and when I clicked on the Network Connect option after logging in, I received the following errors:

Failed to connect to the secure gateway.  Do you want to reconnect?
(nc.windows.app.23792)
and when tried again
Reconnect attempt to the secure gateway failed.
(nc.windows.app.24061)

Any ideas on what causes this error?

Thanks in advance for your help.

Druva
[/quote]

weiwei9

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile