Author Topic: vpls mpls logical system  (Read 629 times)

singerps

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
vpls mpls logical system
« on: August 12, 2016, 09:04:13 am »
Hi!

i am trying to configure next lab on my MX80 (using only logical systems):

CE1---PE1---P1---P2---PE2---CE2

the goal is: to connect CE1 and CE2 at l2 by configuring an vpls-type routing instance on both PE's.

1. i started with configuring an point-to-point links betwet every PE and P routers with lt interfaces - it works fine? every point-to-point ping was successful
 /30 masks , start from 10.10.0.0/30 network.
2. the next one - loopbacks (for bgp in future) -
start with 10.10.10.1/32
3. then i run ospf, on all interfaces, uset passive state on loopbacks, and same - 0.0.0.0 area
at this point every things is also fine - cause i see every routes for PE2 in PE1 routing table, include loopbacks/
4. configuring an BGP using loopbacks, - all sessions are in estabilished state, and routes are recieving and advertising
5. configuring an ldp protocol, and lsp tunnels on each routers in both sides
6.configuring an rsvp protocol, on all interfaces? except loopbacks
lsp tunnel are up after that, labels belongs to PE2 - seen on PE1
7. configuring and routing instances with vpls type command.

after than, assign ip addresses from same subnet to CE1 and CE2 and trying to ping each other - and ping fails.

started troubleshooting:
and find that PE1(PE2) doesn't send and NLRI about routing-instances to their neighbors - P1(P2).
- trying a lot of different solutions finded from different conf guides on juniper site, such as: determining export policies, using same or different interfaces, "using family l2vpn signaling" - state, and etc.

after all that procedures i try to run BGP directly between PE1 and PE2, and it works! both routers are updated information about routing instances of each other.
and actions that i does before has absolutely no effect on this: no matter is there any policies, or anything else - it works only if there direct bgp session between both PE's.

so, any ideas: why?
maybe it is not supposed to work on logical systems in that's setup?