Author Topic: L2 Channel Errors between J6360 and EX3200  (Read 3459 times)

thisisalex02

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-1
    • View Profile
L2 Channel Errors between J6360 and EX3200
« on: March 06, 2012, 06:06:52 pm »
So my setup is pretty simple.  Layer3 interfaces are created on my J series and get trunked to EX which in turn trunks to another Cisco switch where my servers reside.  Issues is on the link between j6350 -> Ex3200 I am getting incrementing L2 channel errors.  This is supposed to be due to the interface receiving a frame where a vlan isnt configured, but I made sure vlans match on both devices yet I am still getting errors.  Any ideas?  Here is my config.

Juniper J6350:

J6360> show interfaces extensive ge-3/0/15 | match L2
    Errors: 0, Drops: 0, Framing errors: 0, Runts: 0, Policed discards: 537, L3 incompletes: 0, L2 channel errors: 8051,
    L2 mismatch timeouts: 0, FIFO errors: 0, Resource errors: 0


Interface config for ge-3/0/15:

description ""
vlan-tagging;
speed 1g;
mtu 1950;
link-mode full-duplex;
gigether-options {
    no-auto-negotiation;
}
unit 0 {
    vlan-id 1;
}
unit 500 {
    vlan-id 500;
}
unit 700 {
    description "";
    vlan-id 700;
    family inet {
        address 192.168.0.254/24;
        address 192.168.8.254/24;
    }
}
unit 900 {
    description "";
    vlan-id 900;
    family inet {
        address 192.168.3.254/24;
    }
}


EX3200:
description "SUPERTRUNK TO GE-3/0/15.TOSA-EDGE1";
mtu 1950;
ether-options {
    no-auto-negotiation;
    link-mode full-duplex;
    speed {
        1g;
    }
}
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ TOSA-VC TOSA-SB-LAN TOSA-WAN ];
        }
        native-vlan-id default;
    }
}


Name           Tag     Interfaces
TOSA-SB-LAN    700   
                       ge-0/0/1.0*, ge-0/0/8.0*
TOSA-VC          900   
                       ge-0/0/1.0*, ge-0/0/2.0*, ge-0/0/3.0*, ge-0/0/4.0*, ge-0/0/6.0*, ge-0/0/7.0*, ge-0/0/8.0*
TOSA-WAN       500   
                       ge-0/0/1.0*, ge-0/0/8.0*
default        999   
                       ge-0/0/1.0*, ge-0/0/8.0*, ge-0/0/9.0, ge-0/0/10.0, ge-0/0/11.0, ge-0/0/12.0, ge-0/0/13.0, ge-0/0/14.0,
                       ge-0/0/15.0, ge-0/0/16.0, ge-0/0/17.0, ge-0/0/18.0, ge-0/0/19.0, ge-0/0/20.0, ge-0/0/21.0, ge-0/0/22.0,
                       ge-0/0/23.0, ge-0/0/24.0, ge-0/0/25.0, ge-0/0/26.0, ge-0/0/27.0, ge-0/0/28.0, ge-0/0/29.0, ge-0/0/30.0,
                       ge-0/0/31.0, ge-0/0/32.0, ge-0/0/33.0, ge-0/0/34.0, ge-0/0/35.0, ge-0/0/36.0, ge-0/0/37.0, ge-0/0/38.0,
                       ge-0/0/39.0, ge-0/0/40.0*, ge-0/0/41.0, ge-0/0/42.0, ge-0/0/43.0*, ge-0/0/44.0, ge-0/0/45.0, ge-0/0/46.0

Thanks in advance.

srames

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: L2 Channel Errors between J6360 and EX3200
« Reply #1 on: March 21, 2012, 03:16:05 pm »
Seems like there is a L2 encapsulation mismatch... :-)