Author Topic: Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure  (Read 8871 times)

azizz

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure
« on: December 15, 2011, 01:26:44 pm »
Dear all,

Recently I purchased a single SRX210H on ebay to learn Junos. It came with Junos 9.6, so I thought I'll upgrade it to 10.4R6.5. Unfortunately I didn't read up enough and now I'm stuck
at u-boot prompt:

U-Boot 1.1.6-JNPR-2.1 (Build time: Jul  4 2011 - 03:55:46)

SRX_210_HIGHMEM board revision major:0, minor:28, serial #: AAAF6883
OCTEON CN5020-SCP pass 1.1, Core clock: 400 MHz, DDR clock: 200 MHz (400 Mhz data rate)
DRAM:  1024 MB
Starting Memory POST...
Checking datalines... OK
Checking address lines... OK
Checking 512K memory for U-Boot... OK.
Running U-Boot CRC Test... OK.
Flash:  4 MB
USB:   scanning bus for devices... 3 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Clearing DRAM........ done
BIST check passed.
Starting PCI
PCI Status: PCI 32-bit
PCI BAR 0: 0xf8000000, PCI BAR 1: Memory 0x00000000  PCI 0x00000000
Un-Protected 1 sectors
writing to flash...
Protected 1 sectors
Boot Media: nand-flash usb
Net:   octeth0
POST Passed
Press SPACE to abort autoboot in 1 seconds
## No elf image at address 0x00100000


I did a quick research and I know that it's possible to recover from this issue following document "How to: Upgrade u-boot and loader on SRX Branch Devices using TFTP method". However, I do not have files for u-boot (u-boot-crc.bin) and loader (loader_crc). Could anybody using SRX210 with 10.4 provide me with these files? (azizz.akhbar@wp.pl)
I forgot to mention that before upgrading I did full system snapshot to USB key (request system snapshot media usb). Perhaps there is a possibility to revert to 9.6?

Thanks for your advices.

azizz

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure
« Reply #1 on: December 15, 2011, 01:59:14 pm »
OK, I guess I've resolved this issue. There was no need to revert back to 9.6.

darcwing

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure
« Reply #2 on: January 18, 2012, 09:02:39 pm »
I am having the the same issue (can't get past the "No ELF image at address..." message) and can't seem to fix this from the u-boot prompt.

Can you tell me how to get this resolved with USB stick and a console cable?  :-)

Thanks
DarcWing

jaredC

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure
« Reply #3 on: January 30, 2012, 10:41:31 pm »
Hi, I too fell in this exact trap of trying to upgrade an SRX210 from 9.6 to 10.4.  Azizz, it looks like you solved this problem in under an hour.  Can you share what you did?  Did you need the u_boot_crc.bin and loader_crc files?

Thanks,

-jaredC

Devotional

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
    • View Profile

jaredC

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure
« Reply #5 on: February 03, 2012, 01:17:00 pm »
Hi,  thanks for the link.  I resolved this issue by upgrading the loader-prompt.  i used tFTP to transfer the file to memory and then installed it using bootupgrade commands from the u-boot prompt. 

The files needed were in the /boot directory of the junos10.0 software download.

If anyone else has this issue, let me know; I can probably assist.   :-)

-JaredC

mach1000

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Upgrading Junos 9.6 -> 10.4 on SRX210, boot failure
« Reply #6 on: July 26, 2012, 02:58:03 am »
Hi guys,

I am spanking new to this forum, and is under education. I have been given a task of "fixing2 one of our srx210 which fails during booting. It stops at the boot => sign, and I cant get to the loader enviroment. It just crashes at "no elf image"

here is the putty output:


U-Boot 1.1.6 (Build time: Apr  9 2009 - 22:31:05)

SRX_210_POE board revision major:0, minor:32, serial #: AAAM2093
OCTEON CN5020-SCP pass 1.1, Core clock: 400 MHz, DDR clock: 200 MHz (400 Mhz data rate)
DRAM:  1024 MB
Flash:  4 MB
WARNING: Running from backup u-boot
USB:   scanning bus for devices... 3 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
POST Passed
Clearing DRAM........ done
BIST check passed.
Starting PCI
PCI Status: PCI 32-bit
PCI BAR 0: 0xf8000000, PCI BAR 1: Memory 0x00000000  PCI 0x00000000
Net:   octeth0
Press SPACE to abort autoboot in 1 seconds
## No elf image at address 0x00100000
=>


I have been trying basically everything, so i would very much appreciate if any of you has a answer for this. I can get it to load the complete image through tftp, but it stops after 128 mb and crashes. i assume it is because of filesize. I then tried to inly mount the boot image inside the complete junos imgae, but still no luck.

Thank you

//M