Author Topic: HSRP through EX8208  (Read 3517 times)

ange

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
HSRP through EX8208
« on: July 19, 2011, 08:45:01 am »
Hi!

I have a little question about compatibility between Cisco and Juniper equipment.

I have two Cisco 6500 configured with HSRP and between them I have two Juniper EX8208 that only do L2 transport.

Here is a little scheme :

                          Cisco 6500-1       Cisco 6500-2
                               |                        |
                               |                        |
                            EX8208 ----------EX8208

On the 6500s:
1 port configured in access mode on a vlan X
1 SVI for the vlan X and HSRP configuration

On the EX8208:
ports linked to the Cisco are in access mode on the vlan X
port linked to the other EX is configured in access mode on the vlan X

With this configuration, both 6500 are in active mode for HSRP because they don't receive the hello packets.
I sniffed the traffic and saw that the hello packets are not transmitted on the link between the two EX.

When I change the SVI configuration for VRRP, everything is ok.

Do you have an idea? :?

Thanks

kshah

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: HSRP through EX8208
« Reply #1 on: July 29, 2011, 09:50:07 am »
You need to make sure no ports in this configuration are in Spanning tree blocking mode. HSRP are just layer 2 UDP multicast hello sent every 3 sec to 224.0.0.2. Where as VRRP hello is a IP packet sent every 1 sec to 224.0.0.18.


Which port do you span on EX 8200 and found no HSRP hello packet are forwarded.

muppet

  • Global Moderator
  • Full Member
  • *****
  • Posts: 211
  • Karma: +0/-0
  • I Like Beer
    • View Profile
    • LiCe for EPIC5
Re: HSRP through EX8208
« Reply #2 on: July 30, 2011, 02:45:14 am »
Also try turning off IGMP snooping and see if that helps.